<!DOCTYPE html>
<!--[if lte IE 7 ]> <html class="ie7" lang="en-US"> <![endif]-->
<!--[if IE 8 ]> <html class="ie8" lang="en-US"> <![endif]-->
<!--[if IE 9 ]> <html class="ie9" lang="en-US"> <![endif]-->
<!--[if (gt IE 9)|!(IE)]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1">
<meta http-equiv="cache-control" content="max-age=0" />
<meta http-equiv="cache-control" content="no-cache" />
<meta http-equiv="expires" content="0" />
<meta http-equiv="expires" content="Tue, 01 Jan 1990 12:00:00 GMT" />
<title>Councilors suggest Bell is forcing Lundy out of office - Weld: Birmingham&#039;s Newspaper</title>

<link rel="stylesheet" href="http://weldbham.com/wp-content/themes/weldbham/style.css?v=130" type="text/css" media="all" />

<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="http://weldbham.com/xmlrpc.php" />

<meta name="google-site-verification" content="7UryHNtSEVdpltewiH7tZLkLO330rzt1FzJi0-JUELA" />

<script type='text/javascript' src='http://partner.googleadservices.com/gampad/google_service.js'>
</script>
<script type='text/javascript'>
GS_googleAddAdSenseService("ca-pub-4522199676001884");
GS_googleEnableAllServices();
</script>
<script type='text/javascript'>
GA_googleAddSlot("ca-pub-4522199676001884", "Weld-Index-Floating");
GA_googleAddSlot("ca-pub-4522199676001884", "Weld-Index-Top");
GA_googleAddSlot("ca-pub-4522199676001884", "Weld-In-Line_1");
GA_googleAddSlot("ca-pub-4522199676001884", "Weld-In-Line_2");
GA_googleAddSlot("ca-pub-4522199676001884", "Weld-In-Line_3");
GA_googleAddSlot("ca-pub-4522199676001884", "Weld-In-Line_4");
</script>
<script type='text/javascript'>
GA_googleFetchAds();
</script>

<!--[if lt IE 9]>
<script src="http://weldbham.com/wp-content/themes/weldbham/js/html5.js" type="text/javascript"></script>
<![endif]-->

<meta name="generator" content="WordPress 4.7.3" />
<meta name="template" content="WeldBham 1.0" />

<!-- This site is optimized with the Yoast SEO plugin v4.5 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="http://weldbham.com/blog/2017/05/23/councilors-suggest-bell-forcing-lundy-office/" />
<!-- / Yoast SEO plugin. -->

<link rel="dns-prefetch" href="//connect.facebook.net" />
<link rel='dns-prefetch' href='//connect.facebook.net' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Weld: Birmingham&#039;s Newspaper &raquo; Feed" href="http://weldbham.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Weld: Birmingham&#039;s Newspaper &raquo; Comments Feed" href="http://weldbham.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Weld: Birmingham&#039;s Newspaper &raquo; Councilors suggest Bell is forcing Lundy out of office Comments Feed" href="http://weldbham.com/blog/2017/05/23/councilors-suggest-bell-forcing-lundy-office/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/weldbham.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.3"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='yarppWidgetCss-css'  href='http://weldbham.com/wp-content/plugins/yet-another-related-posts-plugin/style/widget.css?ver=4.7.3' type='text/css' media='all' />
<link rel='stylesheet' id='fundraiser-css-css'  href='http://weldbham.com/wp-content/themes/weldbham/fundraiser/css/fundraiser.css?ver=1486503694' type='text/css' media='' />
<link rel='stylesheet' id='GoogleAnalyticsAsyncStyle-css'  href='http://weldbham.com/wp-content/plugins/google-analytics-async/ga-async.css?ver=4.7.3' type='text/css' media='all' />
<link rel='stylesheet' id='colorbox-css'  href='http://weldbham.com/wp-content/plugins/slideshow-gallery/views/default/css/colorbox.css?ver=1.3.19' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css'  href='http://weldbham.com/wp-content/plugins/slideshow-gallery/views/default/css/fontawesome.css?ver=4.4.0' type='text/css' media='all' />
<script type='text/javascript' src='http://weldbham.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://weldbham.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://weldbham.com/wp-content/plugins/slideshow-gallery/views/default/js/gallery.js?ver=1.0'></script>
<script type='text/javascript' src='http://weldbham.com/wp-content/plugins/slideshow-gallery/views/default/js/colorbox.js?ver=1.6.3'></script>
<script type='text/javascript' src='http://weldbham.com/wp-content/plugins/slideshow-gallery/views/default/js/jquery-ui.js?ver=4.7.3'></script>
<link rel='https://api.w.org/' href='http://weldbham.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://weldbham.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://weldbham.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='http://weldbham.com/?p=26397' />
<link rel="alternate" type="application/json+oembed" href="http://weldbham.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fweldbham.com%2Fblog%2F2017%2F05%2F23%2Fcouncilors-suggest-bell-forcing-lundy-office%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://weldbham.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fweldbham.com%2Fblog%2F2017%2F05%2F23%2Fcouncilors-suggest-bell-forcing-lundy-office%2F&#038;format=xml" />

        
			<script type="text/javascript">
				var _gaq = _gaq || [];

									_gaq.push(['_setAccount', 'UA-25497493-1']);
											_gaq.push(['_setDomainName', '.weldbham.com']);
						_gaq.push(['_setAllowHash', false]);
										_gaq.push(['_trackPageview']);
											_gaq.push(['_trackPageLoadTime']);
									
				
				(function() {
				var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
				ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
				var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
				})();
			</script>

		<script type="text/javascript"><!--
function powerpress_pinw(pinw_url){window.open(pinw_url, 'PowerPressPlayer','toolbar=0,status=0,resizable=1,width=460,height=320');	return false;}
//-->
</script>
<link rel="stylesheet" type="text/css" href="http://weldbham.com/wp-content/plugins/infomedia-wp-branding75.tmp/css/admin-styles.css" /><script type="text/javascript"> jQuery(document).ready(function(){ jQuery("#wp-admin-bar-wp-logo .ab-item .ab-icon").replaceWith(" <div id=\"custom-admin-logo\"><span class=\"infoicon-icon\"></span></div> ");   }); </script> <meta name="google-site-verification" content="878969361de6ef4b" />
<meta property="og:site_name" content="Weld: Birmingham&#039;s Newspaper" />
<meta property="og:type" content="article" />
<meta property="og:locale" content="en_US" />
<meta property="fb:app_id" content="199569796846147" />
<meta property="og:url" content="http://weldbham.com/blog/2017/05/23/councilors-suggest-bell-forcing-lundy-office/" />
<meta property="og:title" content="Councilors suggest Bell is forcing Lundy out of office" />
<meta property="og:description" content="Speaking both publicly and anonymously, most council members express the belief that the mayor played a&hellip;" />
<meta property="og:image" content="http://weldbham.com/wp-content/uploads/2017/05/Lundy-Time.jpg" />
<meta property="og:image:width" content="2642" />
<meta property="og:image:height" content="3751" />
<meta property="og:image" content="http://weldbham.com/wp-content/uploads/2017/05/DSC_0017.jpg" />
<meta property="og:image:width" content="3008" />
<meta property="og:image:height" content="2000" />
<meta property="og:image" content="http://weldbham.com/wp-content/uploads/2017/05/Lundy.jpg" />
<meta property="og:image:width" content="2642" />
<meta property="og:image:height" content="3751" />
<meta property="article:published_time" content="2017-05-23T22:55:20+00:00" />
<meta property="article:modified_time" content="2017-05-23T22:55:20+00:00" />
<meta property="article:author" content="http://weldbham.com/blog/author/codyowens/" />
<meta property="article:section" content="Breaking News" />
<meta property="article:tag" content="Politics" />
<meta property="article:tag" content="Alabama" />
<meta property="article:tag" content="Birmingham" />
<meta property="article:tag" content="city government" />
<meta property="article:tag" content="corruption" />
<meta property="article:tag" content="Featured" />
<meta property="article:tag" content="jay roberson" />
<meta property="article:tag" content="Johnathan Austin" />
<meta property="article:tag" content="journalism" />
<meta property="article:tag" content="Lashunda Scales" />
<meta property="article:tag" content="marcus lundy" />
<meta property="article:tag" content="reporting" />
<meta property="article:tag" content="William Bell" />

</head>

<body class="wordpress ltr en_US parent-theme multisite blog-1 y2017 m05 d24 h09 wednesday logged-out singular singular-post singular-post-26397 post-format-standard layout-default">
  <div id="shroud" class="shroud">
  <a class="smallnothx" href="#"> x</a>
  <div class="halfsies">
    <div class="leftcont">
      <img class="fourthcheck" src="http://weldbham.com/wp-content/themes/weldbham/fundraiser/images/4th-check-sm.svg">
      <div class="catcher"></div>
      <img class="fpf" src="http://weldbham.com/wp-content/themes/weldbham/fundraiser/images/ktfpf.svg?ver=1" alt="Help Keep the Free Press Free">
      <div class="nothxbox">
        <a class="nothx" href="#"> Not at this time...</a>
      </div>

    </div>
  </div>
  <div class="halfsies">
    <div class="imagewrap">
      <img class="weldlogo" src="http://weldbham.com/wp-content/themes/weldbham/fundraiser/images/weld-logo.svg?ver=1" alt="Weld - Birmingham's Newspaper">
      <img class="freepressfree" src="http://weldbham.com/wp-content/themes/weldbham/fundraiser/images/Help-free-press.svg?ver=1" alt="Help Keep the Free Press Free">
      
                <div class='gf_browser_unknown gform_wrapper' id='gform_wrapper_5' style='display:none'><a id='gf_5' class='gform_anchor' ></a><form method='post' enctype='multipart/form-data' target='gform_ajax_frame_5' id='gform_5'  action='/blog/2017/05/23/councilors-suggest-bell-forcing-lundy-office/#gf_5'>
                        <div class='gform_body'><div id='gform_page_5_1' class='gform_page' >
                                    <div class='gform_page_fields'><ul id='gform_fields_5' class='gform_fields top_label form_sublabel_below description_below'><li id='field_5_6' class='gfield fundraiser-content gfield_html gfield_no_follows_desc field_sublabel_below field_description_below gfield_visibility_visible' >    
    <p><span class="mainline">Journalism is hard. But then again, it’s supposed to be.</span> Not just for the journalist, but for the readers too. You see, true journalism doesn't pander, or protect. It doesn't force feed, regurgitate, or indulge. It serves up a plate of hard-fought facts and places the burden of opinion and cognition on the reader.</p>
<p>
This is your chance to become part of something big – a piece of a publication that forces leaders to leadership, provokes humans toward humanity, and transforms unseeing citizens into enlightened members of a community. The type that makes its readers think, and see, and feel, but never tells them how. We are WELD. We believe in true journalism. And we believe you do too. Join us as we rewrite what true journalism can be.</p></li><li id='field_5_8' class='gfield gfield_price gfield_price_5_8 gfield_product_5_8 gfield_contains_required field_sublabel_below field_description_below gfield_visibility_visible' ><label class='gfield_label'  >Donation Amount<span class='gfield_required'>*</span></label><div class='ginput_container ginput_container_radio'><ul class='gfield_radio' id='input_5_8'><li class='gchoice_5_8_0'><input name='input_8' type='radio' value='$50 Donation|50'  id='choice_5_8_0' tabindex='1'  onclick='gf_apply_rules(5,[9]);' onkeypress='gf_apply_rules(5,[9]);'  /><label for='choice_5_8_0' id='label_5_8_0'>Donate $50</label></li><li class='gchoice_5_8_1'><input name='input_8' type='radio' value='$100 Donation|100'  id='choice_5_8_1' tabindex='2'  onclick='gf_apply_rules(5,[9]);' onkeypress='gf_apply_rules(5,[9]);'  /><label for='choice_5_8_1' id='label_5_8_1'>Donate $100</label></li><li class='gchoice_5_8_2'><input name='input_8' type='radio' value='$250 Donation|250'  id='choice_5_8_2' tabindex='3'  onclick='gf_apply_rules(5,[9]);' onkeypress='gf_apply_rules(5,[9]);'  /><label for='choice_5_8_2' id='label_5_8_2'>Donate $250</label></li><li class='gchoice_5_8_3'><input name='input_8' type='radio' value='$500 Donation|500'  id='choice_5_8_3' tabindex='4'  onclick='gf_apply_rules(5,[9]);' onkeypress='gf_apply_rules(5,[9]);'  /><label for='choice_5_8_3' id='label_5_8_3'>Donate $500</label></li><li class='gchoice_5_8_4'><input name='input_8' type='radio' value='$1,000 Donation|1000'  id='choice_5_8_4' tabindex='5'  onclick='gf_apply_rules(5,[9]);' onkeypress='gf_apply_rules(5,[9]);'  /><label for='choice_5_8_4' id='label_5_8_4'>Donate $1,000</label></li><li class='gchoice_5_8_5'><input name='input_8' type='radio' value='$5,000 Donation|5000'  id='choice_5_8_5' tabindex='6'  onclick='gf_apply_rules(5,[9]);' onkeypress='gf_apply_rules(5,[9]);'  /><label for='choice_5_8_5' id='label_5_8_5'>Donate $5,000</label></li><li class='gchoice_5_8_6'><input name='input_8' type='radio' value='Donation|0'  id='choice_5_8_6' tabindex='7'  onclick='gf_apply_rules(5,[9]);' onkeypress='gf_apply_rules(5,[9]);'  /><label for='choice_5_8_6' id='label_5_8_6'>Other Amount</label></li></ul></div></li><li id='field_5_9' class='gfield gfield_price gfield_price_5_9 gfield_product_5_9 gfield_contains_required field_sublabel_below field_description_below gfield_visibility_visible' ><label class='gfield_label' for='input_5_9' >Other Amount<span class='gfield_required'>*</span></label><div class='ginput_container ginput_container_product_price'>
					<input name='input_9' id='input_5_9' type='text' value='' class='large ginput_amount' tabindex='8'  placeholder='Other Amount' aria-required="true" aria-invalid="false" />
				</div></li></ul>
                    </div>
                    <div class='gform_page_footer'>
                         <input type='button' id='gform_next_button_5_3' class='gform_next_button button' value='Next' tabindex='9' onclick='jQuery("#gform_target_page_number_5").val("2");  jQuery("#gform_5").trigger("submit",[true]); ' onkeypress='if( event.keyCode == 13 ){ jQuery("#gform_target_page_number_5").val("2");  jQuery("#gform_5").trigger("submit",[true]); } ' /> 
                    </div>
                </div>
                <div id='gform_page_5_2' class='gform_page' style='display:none;'>
                    <div class='gform_page_fields'>
                        <ul id='gform_fields_5_2' class='gform_fields top_label form_sublabel_below description_below'><li id='field_5_10' class='gfield gfield_html gfield_html_formatted gfield_no_follows_desc field_sublabel_below field_description_below gfield_visibility_visible' ><h2>Additional Information</h2></li><li id='field_5_1' class='gfield gfield_contains_required field_sublabel_below field_description_below gfield_visibility_visible' ><label class='gfield_label gfield_label_before_complex' for='input_5_1_3' >Name<span class='gfield_required'>*</span></label><div class='ginput_complex ginput_container no_prefix has_first_name no_middle_name has_last_name no_suffix gf_name_has_2 ginput_container_name gfield_trigger_change' id='input_5_1'>
                            
                            <span id='input_5_1_3_container' class='name_first' >
                                                    <input type='text' name='input_1.3' id='input_5_1_3' value='' aria-label='First name' tabindex='11'  aria-required="true" aria-invalid="false" />
                                                    <label for='input_5_1_3' >First</label>
                                                </span>
                            
                            <span id='input_5_1_6_container' class='name_last' >
                                                    <input type='text' name='input_1.6' id='input_5_1_6' value='' aria-label='Last name' tabindex='13'  aria-required="true" aria-invalid="false" />
                                                    <label for='input_5_1_6' >Last</label>
                                                </span>
                            
                        </div></li><li id='field_5_5' class='gfield gfield_contains_required field_sublabel_below field_description_below gfield_visibility_visible' ><label class='gfield_label' for='input_5_5' >Email<span class='gfield_required'>*</span></label><div class='ginput_container ginput_container_email'>
                            <input name='input_5' id='input_5_5' type='text' value='' class='large' tabindex='15'    aria-required="true" aria-invalid="false"/>
                        </div></li><li id='field_5_2' class='gfield gfield_contains_required field_sublabel_below field_description_below gfield_visibility_visible' ><label class='gfield_label gfield_label_before_complex' for='input_5_2_1' >Address<span class='gfield_required'>*</span></label>    
                    <div class='ginput_complex ginput_container has_street has_street2 has_city has_state has_zip ginput_container_address gfield_trigger_change' id='input_5_2' >
                         <span class='ginput_full address_line_1' id='input_5_2_1_container' >
                                        <input type='text' name='input_2.1' id='input_5_2_1' value='' tabindex='16'  />
                                        <label for='input_5_2_1' id='input_5_2_1_label' >Street Address</label>
                                    </span><span class='ginput_full address_line_2' id='input_5_2_2_container' >
                                        <input type='text' name='input_2.2' id='input_5_2_2' value='' tabindex='17'  />
                                        <label for='input_5_2_2' id='input_5_2_2_label' >Address Line 2</label>
                                    </span><span class='ginput_left address_city' id='input_5_2_3_container' >
                                    <input type='text' name='input_2.3' id='input_5_2_3' value='' tabindex='18'  />
                                    <label for='input_5_2_3' id='input_5_2_3_label' >City</label>
                                 </span><span class='ginput_right address_state' id='input_5_2_4_container' >
                                        <select name='input_2.4' id='input_5_2_4' tabindex='19'   ><option value='' selected='selected'></option><option value='Alabama' >Alabama</option><option value='Alaska' >Alaska</option><option value='Arizona' >Arizona</option><option value='Arkansas' >Arkansas</option><option value='California' >California</option><option value='Colorado' >Colorado</option><option value='Connecticut' >Connecticut</option><option value='Delaware' >Delaware</option><option value='District of Columbia' >District of Columbia</option><option value='Florida' >Florida</option><option value='Georgia' >Georgia</option><option value='Hawaii' >Hawaii</option><option value='Idaho' >Idaho</option><option value='Illinois' >Illinois</option><option value='Indiana' >Indiana</option><option value='Iowa' >Iowa</option><option value='Kansas' >Kansas</option><option value='Kentucky' >Kentucky</option><option value='Louisiana' >Louisiana</option><option value='Maine' >Maine</option><option value='Maryland' >Maryland</option><option value='Massachusetts' >Massachusetts</option><option value='Michigan' >Michigan</option><option value='Minnesota' >Minnesota</option><option value='Mississippi' >Mississippi</option><option value='Missouri' >Missouri</option><option value='Montana' >Montana</option><option value='Nebraska' >Nebraska</option><option value='Nevada' >Nevada</option><option value='New Hampshire' >New Hampshire</option><option value='New Jersey' >New Jersey</option><option value='New Mexico' >New Mexico</option><option value='New York' >New York</option><option value='North Carolina' >North Carolina</option><option value='North Dakota' >North Dakota</option><option value='Ohio' >Ohio</option><option value='Oklahoma' >Oklahoma</option><option value='Oregon' >Oregon</option><option value='Pennsylvania' >Pennsylvania</option><option value='Rhode Island' >Rhode Island</option><option value='South Carolina' >South Carolina</option><option value='South Dakota' >South Dakota</option><option value='Tennessee' >Tennessee</option><option value='Texas' >Texas</option><option value='Utah' >Utah</option><option value='Vermont' >Vermont</option><option value='Virginia' >Virginia</option><option value='Washington' >Washington</option><option value='West Virginia' >West Virginia</option><option value='Wisconsin' >Wisconsin</option><option value='Wyoming' >Wyoming</option><option value='Armed Forces Americas' >Armed Forces Americas</option><option value='Armed Forces Europe' >Armed Forces Europe</option><option value='Armed Forces Pacific' >Armed Forces Pacific</option></select>
                                        <label for='input_5_2_4' id='input_5_2_4_label' >State</label>
                                      </span><span class='ginput_left address_zip' id='input_5_2_5_container' >
                                    <input type='text' name='input_2.5' id='input_5_2_5' value='' tabindex='21'  />
                                    <label for='input_5_2_5' id='input_5_2_5_label' >ZIP Code</label>
                                </span><input type='hidden' class='gform_hidden' name='input_2.6' id='input_5_2_6' value='United States'/>
                    <div class='gf_clear gf_clear_complex'></div>
                </div></li><li id='field_5_11' class='gfield gfield_html gfield_html_formatted gfield_no_follows_desc field_sublabel_below field_description_below gfield_visibility_visible' ><div class="frdescription"> Thank you for your donation! You'll be sent to PayPal to complete the transaction. </div></li>
                            </ul></div>
        <div class='gform_page_footer top_label'><input type='submit' id='gform_previous_button_5' class='gform_previous_button button' value='« Change Donation Amount' tabindex='22' onclick='if(window["gf_submitting_5"]){return false;}  window["gf_submitting_5"]=true;  ' onkeypress='if( event.keyCode == 13 ){ if(window["gf_submitting_5"]){return false;} window["gf_submitting_5"]=true;  jQuery("#gform_5").trigger("submit",[true]); }' /> <input type='submit' id='gform_submit_button_5' class='gform_button button' value='Donate!' tabindex='23' onclick='if(window["gf_submitting_5"]){return false;}  window["gf_submitting_5"]=true;  ' onkeypress='if( event.keyCode == 13 ){ if(window["gf_submitting_5"]){return false;} window["gf_submitting_5"]=true;  jQuery("#gform_5").trigger("submit",[true]); }' /> <input type='hidden' name='gform_ajax' value='form_id=5&amp;title=&amp;description=&amp;tabindex=0' />
            <input type='hidden' class='gform_hidden' name='is_submit_5' value='1' />
            <input type='hidden' class='gform_hidden' name='gform_submit' value='5' />
            
            <input type='hidden' class='gform_hidden' name='gform_unique_id' value='' />
            <input type='hidden' class='gform_hidden' name='state_5' value='WyJ7XCI4XCI6W1wiNjQ2OWNjM2I3MjJhYmExNzE0NTBkMzAxZDEzNmFhZGFcIixcImNjZTgyODA0MjFhNTYyZTFlYzk4NDJiZmFmMzAxZjY1XCIsXCIyMTNjNThmYTA0MWY4NTkwYmNhNzVlM2Y2Mjk4MjhkNVwiLFwiOWZkZDg1MTY1NTg2ZDdjNTY1MWVmNzkzOTIyYTQwYWJcIixcIjE5MTk1YmY4NDY2NTgwZmE5M2U1OWRmY2Y2ZTEzYzY4XCIsXCJhOGMzYWY3M2UyNjI1MzFiNGI2MzRkOTMyYjQ2YmQxY1wiLFwiYTM3YjQyMTgxODhjZWM5NWM5ZGRiMTg1N2I1NmY5MGZcIl19IiwiYjNmZGViNzgzYWFkMzgyYTI2NGQ2MTIwMDM3Nzk0NWUiXQ==' />
            <input type='hidden' class='gform_hidden' name='gform_target_page_number_5' id='gform_target_page_number_5' value='2' />
            <input type='hidden' class='gform_hidden' name='gform_source_page_number_5' id='gform_source_page_number_5' value='1' />
            <input type='hidden' name='gform_field_values' value='' />
            
        </div>
                        </div></div>
                        </form>
                        </div>
                <iframe style='display:none;width:0px;height:0px;' src='about:blank' name='gform_ajax_frame_5' id='gform_ajax_frame_5'>This iframe contains the logic required to handle AJAX powered Gravity Forms.</iframe>
                <script type='text/javascript'>jQuery(document).ready(function($){gformInitSpinner( 5, 'http://weldbham.com/wp-content/plugins/gravityforms/images/spinner.gif' );jQuery('#gform_ajax_frame_5').load( function(){var contents = jQuery(this).contents().find('*').html();var is_postback = contents.indexOf('GF_AJAX_POSTBACK') >= 0;if(!is_postback){return;}var form_content = jQuery(this).contents().find('#gform_wrapper_5');var is_confirmation = jQuery(this).contents().find('#gform_confirmation_wrapper_5').length > 0;var is_redirect = contents.indexOf('gformRedirect(){') >= 0;var is_form = form_content.length > 0 && ! is_redirect && ! is_confirmation;if(is_form){jQuery('#gform_wrapper_5').html(form_content.html());if(form_content.hasClass('gform_validation_error')){jQuery('#gform_wrapper_5').addClass('gform_validation_error');} else {jQuery('#gform_wrapper_5').removeClass('gform_validation_error');}setTimeout( function() { /* delay the scroll by 50 milliseconds to fix a bug in chrome */ jQuery(document).scrollTop(jQuery('#gform_wrapper_5').offset().top); }, 50 );if(window['gformInitDatepicker']) {gformInitDatepicker();}if(window['gformInitPriceFields']) {gformInitPriceFields();}var current_page = jQuery('#gform_source_page_number_5').val();gformInitSpinner( 5, 'http://weldbham.com/wp-content/plugins/gravityforms/images/spinner.gif' );jQuery(document).trigger('gform_page_loaded', [5, current_page]);window['gf_submitting_5'] = false;}else if(!is_redirect){var confirmation_content = jQuery(this).contents().find('#gforms_confirmation_message_5').html();if(!confirmation_content){confirmation_content = contents;}setTimeout(function(){jQuery('#gform_wrapper_5').replaceWith('<' + 'div id=\'gforms_confirmation_message_5\' class=\'gform_confirmation_message_5 gforms_confirmation_message\'' + '>' + confirmation_content + '<' + '/div' + '>');jQuery(document).scrollTop(jQuery('#gforms_confirmation_message_5').offset().top);jQuery(document).trigger('gform_confirmation_loaded', [5]);window['gf_submitting_5'] = false;}, 50);}else{jQuery('#gform_5').append(contents);if(window['gformRedirect']) {gformRedirect();}}jQuery(document).trigger('gform_post_render', [5, current_page]);} );} );</script><script type='text/javascript'> if(typeof gf_global == 'undefined') var gf_global = {"gf_currency_config":{"name":"U.S. Dollar","symbol_left":"$","symbol_right":"","symbol_padding":"","thousand_separator":",","decimal_separator":".","decimals":2},"base_url":"http:\/\/weldbham.com\/wp-content\/plugins\/gravityforms","number_formats":[],"spinnerUrl":"http:\/\/weldbham.com\/wp-content\/plugins\/gravityforms\/images\/spinner.gif"};jQuery(document).bind('gform_post_render', function(event, formId, currentPage){if(formId == 5) {gf_global["number_formats"][5] = {"6":{"price":false,"value":false},"8":{"price":"decimal_dot","value":false},"9":{"price":"decimal_dot","value":false},"3":{"price":false,"value":false},"10":{"price":false,"value":false},"1":{"price":false,"value":false},"5":{"price":false,"value":false},"2":{"price":false,"value":false},"11":{"price":false,"value":false}};if(window['jQuery']){if(!window['gf_form_conditional_logic'])window['gf_form_conditional_logic'] = new Array();window['gf_form_conditional_logic'][5] = { logic: { 9: {"field":{"actionType":"show","logicType":"all","rules":[{"fieldId":"8","operator":"is","value":"Donation"}]},"nextButton":null,"section":null} }, dependents: { 9: [9] }, animation: 0, defaults: {"1":{"1.2":"","1.3":"","1.4":"","1.6":"","1.8":""},"2":{"2.1":"","2.2":"","2.3":"","2.4":"","2.5":"","2.6":"United States"}}, fields: {"6":[],"8":[9],"9":[],"3":[],"10":[],"1":[],"5":[],"2":[],"11":[]} }; if(!window['gf_number_format'])window['gf_number_format'] = 'decimal_dot';jQuery(document).ready(function(){gf_apply_rules(5, [9], true);jQuery('#gform_wrapper_5').show();jQuery(document).trigger('gform_post_conditional_logic', [5, null, true]);} );} if(window["gformInitPriceFields"]) jQuery(document).ready(function(){gformInitPriceFields();} );if(typeof Placeholders != 'undefined'){
                        Placeholders.enable();
                    }} } );jQuery(document).bind('gform_post_conditional_logic', function(event, formId, fields, isInit){} );</script><script type='text/javascript'> jQuery(document).ready(function(){jQuery(document).trigger('gform_post_render', [5, 1]) } ); </script>    </div>
  </div>
</div>	
	<div id="container">
		
		
	<header id="header" role="banner">
	
			
		<div class="wrap">
	                
			<hgroup id="branding">
				
				<h1 id="site-title"><a href="http://weldbham.com/" title="Weld: Birmingham&#039;s Newspaper"><span>Weld: Birmingham&#039;s Newspaper</span></a></h1>
				
				<h2 id="site-description">Where Birmingham Gets Connected</h2>									
			
			</hgroup><!-- #branding -->		
	
			
	
	<nav id="menu-primary" role="navigation" class="primary-navigation site-navigation">
		<h1 class="assistive-text">Menu</h1>
		<div class="assistive-text skip-link"><a href="#content" title="Skip to content">Skip to content</a></div>
		
		<div class="wrap">

						<div class="s">

				<form method="get" class="searchform" action="http://weldbham.com/">
					<input class="search-text" type="text" name="s" value="Search Weld" onfocus="if(this.value==this.defaultValue)this.value='';" onblur="if(this.value=='')this.value=this.defaultValue;" />
					<input class="search-submit button" name="submit" type="submit" value="Go" />
				</form><!-- .search-form -->

			</div><!-- .search -->
			
			
			<div class="menu"><ul id="menu-primary-items" class="nav-menu"><li id="menu-item-11174" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-11174"><a href="http://weldbham.com/">Home</a></li>
<li id="menu-item-12085" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12085"><a href="http://weldbham.com/login/">Login</a></li>
<li id="menu-item-11136" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-11136"><a href="http://weldbham.com/about/">About Us</a></li>
<li id="menu-item-26275" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-26275"><a href="http://weldbham.com/blog/2017/05/01/documenting-hate-weld-new-american-media/">&#8220;Documenting Hate&#8221;</a></li>
<li id="menu-item-11135" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-11135"><a href="http://weldbham.com/advertise/">Advertise</a></li>
</ul></div>
						
		</div>

	</nav><!-- #menu-primary .menu-container -->

	

	
	<nav id="menu-secondary" role="navigation" class="secondary-navigation site-navigation">
		<h1 class="assistive-text">Menu</h1>
		<div class="assistive-text skip-link"><a href="#content" title="Skip to content">Skip to content</a></div>

		<div class="wrap">

			
			<div class="menu"><ul id="menu-secondary-items" class="secondary"><li id="menu-item-11175" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-11175"><a href="http://weldbham.com/blog/category/news-views/">News &#038; Views</a></li>
<li id="menu-item-23261" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-23261"><a href="http://weldbham.com/blog/category/community/">Community</a></li>
<li id="menu-item-23263" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-23263"><a href="http://weldbham.com/blog/category/column/">Column</a></li>
<li id="menu-item-23262" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-23262"><a href="http://weldbham.com/blog/category/life-leisure/food-drink/">Food &#038; Drink</a></li>
<li id="menu-item-23260" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-23260"><a href="http://weldbham.com/blog/category/art-culture/music/">Music</a></li>
<li id="menu-item-24710" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24710"><a href="http://weldbham.com/blog/category/weldcast/">WeldCast</a></li>
</ul></div>
						
		</div><!-- .wrap -->
		

	</nav><!-- #menu-secondary .menu-container -->

	
			
				
			
		</div><!-- .wrap -->
	
			
	</header><!-- #header -->

	
		<div id="main">
		
			

			<div class="wrap">			
	
	<div id="content" role="main">

		
		<section class="hfeed">
		
		
			
				
					
<article id="post-26397" class="hentry post publish post-1 odd author-codyowens has-excerpt format-standard category-breaking-news category-news-politics post_tag-alabama post_tag-birmingham post_tag-city-government post_tag-corruption post_tag-featured post_tag-jay-roberson post_tag-johnathan-austin post_tag-journalism post_tag-lashunda-scales post_tag-marcus-lundy post_tag-reporting post_tag-william-bell">

	
	<header class="entry-header clearfix">
	
		<div class="article-info">
			
			<div class="singular-categories"><span class="category"><a href="http://weldbham.com/blog/category/news-views/breaking-news/" rel="tag">Breaking News</a>, <a href="http://weldbham.com/blog/category/news-views/news-politics/" rel="tag">Politics</a></span></div>		
		</div>

		<div class="article-main">
			
			<div class="byline"><abbr class="published" title="Tuesday, May 23rd, 2017, 4:55 pm">May 23, 2017</abbr> </div>
			<h1 class="entry-title">Councilors suggest Bell is forcing Lundy out of office</h1>		
					
		</div>
	
	</header><!-- .entry-header -->
	
	
		<div class="article-info">
			
	
			<div class="author-description">
				
				<img alt='Cody Owens' src='http://weldbham.com/wp-content/uploads/2017/02/Cody-Owens_avatar_1488227775-106x106.jpg' class='avatar avatar-106 photo' height='106' width='106' />	
				<div class="user-bio author-bio"> <h3 class="author-title fn n"><a href="http://weldbham.com/blog/author/codyowens/">Cody Owens</a></h3><p class="author-name">Cody is a staff reporter for Weld. He writes about politics in Birmingham as well as social issues and breaking news. Contact him at cody@weldbham.com.</p>				</div><!-- .user-bio .author-bio -->
				<div class="subscribe-info"> <h3 class="share-title">Share</h3><span class="sitefeed"><a href="https://twitter.com/share" class="twitter-share-button" data-via="WeldBham" data-dnt="true">Tweet</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="//platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script><form>
								<input type="text" name="shorturl" value="http://weldbham.com/?p=26397">
							</form></span><br><h3 class="subscribe-title">Subscribe</h3><span class="sitefeed"><a href="http://weldbham.com/feed/rss/">Weld: Birmingham&#039;s Newspaper</a></span><br /><span class="author-feed"><a href="http://weldbham.com/blog/author/codyowens/feed">Cody Owens</a></span>				</div>
			</div><!-- .loop-description -->
		</div><!-- .article-info -->	
	<div class="article-main">
	
		<div class="single-entry-summary">
			Speaking both publicly and anonymously, most council members express the belief that the mayor played a role in one member not seeking re-election.		</div><!-- .entry-summary -->
		
				
			
		<div class="entry-content">
			<div id="attachment_26400" class="wp-caption alignright" style="width: 280px"><img class="size-feature wp-image-26400" src="http://weldbham.com/wp-content/uploads/2017/05/Lundy-280x410.jpg" alt="" width="280" height="410" /><p class="wp-caption-text">At the May 23 city council meeting, Councilor Marcus Lundy announced that he would not seek re-election. Photo by Sam Prickett.</p></div>
<div class="mceTemp">Birmingham City Councilor Marcus Lundy announced on Tuesday he will not be seeking re-election, leading to an outpouring of verbal — and at times outwardly emotional — support from his fellow councilors, with some indicating they believe he was forced out.</div>
<p><span style="font-weight: 400;">A majority of the council members, speaking both on record and anonymously after the meeting, allege that Lundy was pressured to not seek re-election by Mayor William Bell or else potentially lose his job at Regions Bank. </span></p>
<p><span style="font-weight: 400;">“The book of Ecclesiastes says there is a time to plant and a time to uproot, a time to live and a time to die. For all things there is a season, and my time as a city councilor has come to an end,” Lundy said. “I will not be seeking re-election for Birmingham City Council. This information will satisfy a lot of folks. They’re probably doing cartwheels right now.”</span></p>
<p><span style="font-weight: 400;">Lundy did not say which “folks” he was referring to, but the announcement sent shockwaves through the nearly empty council chambers. </span></p>
<p><span style="font-weight: 400;">Following his remarks, several councilors alluded to the altercation between Lundy and Bell that occurred on December 15, 2015 during a council meeting. In that widely publicized event, there was shouting in the room behind the council chamber and a brief scuffle which sent both men to the hospital with minor injuries. A warrant was initially issued for Lundy but later withdrawn at Bell’s request. </span></p>
<p><span style="font-weight: 400;">The incident made national headlines and left a bruise on the relationship between Bell and the council, one that was made visible by the public comments made by members of the council on Tuesday after most of the media and citizens in attendance had left the meeting. </span></p>
<p><span style="font-weight: 400;">“This is not something you should be doing for 40 years,” Lundy said, seeming to refer to the number of years Bell has been at city hall. “Ideas get old and stale, just as you do. And you should come in here, add value and then get the hell out of the way… I thank God for my time here, but y’all won’t have Lundy to beat around no more.”</span></p>
<p><span style="font-weight: 400;">According a member of the council, who spoke after the meeting and asked to remain anonymous out of fear of retribution, Lundy was told by the mayor that if he sought re-election, he would lose his job at Regions Bank. “The mayor and Regions executives conspired to fire him if he ran again,” the councilor said. </span></p>
<p><span style="font-weight: 400;">Several other councilors, according to the source, have been subjected to similar threats by the mayor’s office. Another councilor confirmed separately that they believe these allegations to be true. During the public meeting some council members spoke out about the situation, but stopped short of making outright accusations that Bell pressured Lundy to not seek re-election.</span></p>
<p><span style="font-weight: 400;">They did, however, strongly suggest that Lundy was the victim of an injustice that needs balancing out. </span></p>
<p><span style="font-weight: 400;">“It’s unfortunate you have to make a decision like this,” Councilor Steven Hoyt said, addressing Lundy during the meeting. “But the God that we serve is the God of reciprocity. What goes around comes around. So do know that. I’m telling you the day of reckoning will come when things will be dealt with like they should… I understand at the end of the day, it’s about family and it’s about business. But we wish you the very best.”</span></p>
<p><span style="font-weight: 400;">Councilor Sheila Tyson said that nobody should have to decide between public service and keeping a job. “It’s not right… I know you aren’t going to agree on everything, but you shouldn’t have to choose between your job and serving the public,” she said. “I think people take this as a game. They do things out of spite. To be playing with someone’s job is so wrong. I promise you, what goes around comes around.”</span></p>
<p><span style="font-weight: 400;">In the current climate at city hall, serving as a council member is “not an illustrious position,” Councilor Jay Roberson said from the dais. “You got a wife and kids. You have got to do what’s best for your family. I commend you for coming out and being open, honest, and abrupt about your decision. It takes a real man to do that under these circumstances.”</span></p>
<div id="attachment_26398" class="wp-caption alignnone" style="width: 460px"><img class="size-large wp-image-26398" src="http://weldbham.com/wp-content/uploads/2017/05/DSC_0017-460x306.jpg" alt="" width="460" height="306" srcset="http://weldbham.com/wp-content/uploads/2017/05/DSC_0017-460x306.jpg 460w, http://weldbham.com/wp-content/uploads/2017/05/DSC_0017-200x133.jpg 200w, http://weldbham.com/wp-content/uploads/2017/05/DSC_0017-768x511.jpg 768w" sizes="(max-width: 460px) 100vw, 460px" /><p class="wp-caption-text">Lashunda Scales says she has been subject to instances of &#8220;bullying&#8221; at City Hall during her tenure as councilor. Photo by Cody Owens.</p></div>
<p><span style="font-weight: 400;">Having been out of the chamber during the announcement, Councilor Lashunda Scales was visibly upset, wiping tears away, when she realized what was happening. She entered the room after the other councilors had commented on the situation.</span></p>
<p><span style="font-weight: 400;">“It should be on your own will and not because you were forced to have to choose… I’m heartbroken, because if the public only knew the bullying that goes on in this place&#8230; I’m so sick of it,” a teary-eyed Scales said. “I’m going to tell them, but I’m going to do it at the right time. This is the only job that, physically — that I came to work and had to question if my safety would be at risk. This is crazy. You’re talking about folks’ family!”</span></p>
<p><span style="font-weight: 400;">Scales, who said she was “fed up,” characterized City Hall as the place “where dreams come to die.” Without divulging details, Scales said she will open up about an incident that happened to her in 2013 “when the time is right.” She followed by saying similar situations of “bullying” have happened to other councilors as well. </span></p>
<p><span style="font-weight: 400;">“You have a councilor being dismissed from a job they held for almost 30 years,” Scales said. “You got another council member whose job is in question because if you don’t make certain political decisions… That’s not the democratic way of doing things.”</span></p>
<p><span style="font-weight: 400;">She said she is praying the CIA or FBI — “Forget the local district attorney; he’s probably hamstrung too on some level,” she said — would investigate the alleged corruption in the mayor’s office. “Mr. Lundy, I’m not going to take this lying down. This is why good people don’t run for office. The crooks will run for it,” Scales said. “I hope this place gets exposed for everything it is… I promise you, this year I’m going to tell everything I know. I’m hurting for you, Mr. Lundy… I’m hurt. And I’ll tell you, hell hath no fury like a woman scorned.”</span></p>
<p><span style="font-weight: 400;">When asked via email if there was any validity to these allegations, April Odom, communications director for Bell, responded with an emoticon-ended comment that did not address the issue. “</span><span style="font-weight: 400;">I know that you are doing your job. ;)” she wrote. When asked whether or not an additional response would be given, Odom wrote, “No.”</span></p>
<p><span style="font-weight: 400;">A representative for Regions Bank said “they have no comment at this time” regarding the allegations of collusion between Bell and Regions executives in regards to Lundy’s future employment. After the meeting, Lundy could not be reached for further comment.   </span></p>

<div class="fb-social-plugin fb-like" data-font="lucida grande" data-ref="below-post" data-href="http://weldbham.com/blog/2017/05/23/councilors-suggest-bell-forcing-lundy-office/" data-show-faces="true" data-width="300"></div>
					</div><!-- .entry-content -->
		
			
	</div><!-- .article-main -->

	
	
</article><!-- .hentry -->




<div id="comments" class="comments-area">
<div id="respond" class="comment-respond">
<div class="fb-social-plugin comment-form fb-comments" id="commentform" data-href="http://weldbham.com/blog/2017/05/23/councilors-suggest-bell-forcing-lundy-office/" data-width="470" data-num-posts="20"></div>
</div></div>

<div class='yarpp-related'>

<div class="related-posts banner top-clip grey">
	<div class="bottom-clip inner clearfix">
		
		<h3>Related:</h3>
		
				
		<ul>
		
						
			<li>
				<a href="http://weldbham.com/blog/2017/05/10/city-council-report-dont-toot-horn/" rel="bookmark">City Council Report: If You Don’t Toot Your Own Horn&#8230;</a>
				<span class="related-date">May 10, 2017</span><!-- (17.9)--></li>
			
						
			<li>
				<a href="http://weldbham.com/blog/2017/03/14/city-council-report-mayors-men/" rel="bookmark">City Council Report: All the Mayor&#8217;s Men?</a>
				<span class="related-date">March 14, 2017</span><!-- (16.2)--></li>
			
						
			<li>
				<a href="http://weldbham.com/blog/2016/05/10/johnathan-austin-re-elected-as-city-council-president/" rel="bookmark">Johnathan Austin re-elected as city council president</a>
				<span class="related-date">May 10, 2016</span><!-- (16.7)--></li>
			
						
			<li>
				<a href="http://weldbham.com/blog/2015/01/13/ring-the-bell-birmingham/" rel="bookmark">Ring the Bell</a>
				<span class="related-date">January 13, 2015</span><!-- (16.6)--></li>
			
					
		</ul>
		
			
	</div>
</div>
</div>

				
						
			
		</section><!-- .hfeed -->

		
		
	<div class="loop-nav clearfix">
		
		<div class="previous"><a href=" http://weldbham.com/blog/2017/05/08/mayoral-candidate-randy-davis-wants-bring-community-city-hall-closer-together/"><a href="http://weldbham.com/blog/2017/05/08/mayoral-candidate-randy-davis-wants-bring-community-city-hall-closer-together/" title="Mayoral candidate Randy Davis wants to bring the community and City Hall closer together"><img src="http://weldbham.com/wp-content/uploads/2017/05/Randy-Davis-photo-106x106.jpg" alt="Photo courtesy of Randy Davis." class="Thumbnail thumbnail " /></a></a><a href=" http://weldbham.com/blog/2017/05/08/mayoral-candidate-randy-davis-wants-bring-community-city-hall-closer-together/" rel="prev"><div class="nav-info"><span class="nav-above block">Previous</span><h5>Mayoral candidate Randy Davis wants to bring the community and City Hall closer together</h5><abbr class="published">May 8, 2017</abbr></div></a></div>	
	</div><!-- .loop-nav -->

		
				<script type='text/javascript'>
			var window_innerwidth = window.innerWidth;
			if (window_innerwidth < 630 ) {
				GA_googleFillSlot("Weld-Index-Top");
			} else if (window_innerwidth >= 630 && window_innerwidth < 728 ) {
				GA_googleFillSlot("Weld-In-Line_2");
			} else if (window_innerwidth >= 728 && window_innerwidth < 950 ) {
				GA_googleFillSlot("Weld-Index-Top");
			} else {
				GA_googleFillSlot("Weld-In-Line_2");
			}
		</script> 
	</div><!-- #content -->



				
	
	<div id="sidebar-primary" class="sidebar" role="complementary">
    
    <div class="frside">
      <div class="frhead">
        <img class="frlogo" src="http://weldbham.com/wp-content/themes/weldbham/fundraiser/images/sidebar-weld.svg" alt="Weld - Donate Today!">
                <ul>
          <li><a data-donate="$50 Donation|50" href="#">Donate $50</a></li>
          <li><a data-donate="$100 Donation|100" href="#">Donate $100</a></li>
          <li><a data-donate="$250 Donation|250" href="#">Donate $250</a></li>
          <li><a data-donate="$500 Donation|500" href="#">Donate $500</a></li>
          <li><a data-donate="$1,000 Donation|1000" href="#">Donate $1,000</a></li>
          <li><a data-donate="$5,000 Donation|5000" href="#">Donate $5,000</a></li>
        </ul>
      </div>
    </div>
		
		<aside id="text-14" class="widget widget_text widget-widget_text">			<div class="textwidget"><div class="latest-banner"></div>
<a href="http://weldbham.com/issues/may-18-25-2017/"><img width="300" height="410" src="http://weldbham.com/wp-content/uploads/2017/05/Weld-0518.17-page-1-300x410.jpg" class="attachment-issue size-issue wp-post-image" alt="" /></a></div>
		</aside><aside id="text-16" class="widget widget_text widget-widget_text">			<div class="textwidget"><div id="fixedAd" class="sidebar-ad">
<!-- Weld-fixed-ad -->
<script type='text/javascript'>
		if (window.innerWidth >= 728 && window.innerWidth < 950 ) {
			GA_googleFillSlot("Weld-Index-Top_Mobile");
		} else {
			GA_googleFillSlot("Weld-Index-Top");
		}
</script>
</div></div>
		</aside><aside id="text-13" class="widget widget_text widget-widget_text">			<div class="textwidget">			<div class="blue sidebar-form">
				<div class="banner top-clip">
					<div class="bottom-clip inner clearfix">

                <div class='gf_browser_unknown gform_wrapper' id='gform_wrapper_2' ><a id='gf_2' class='gform_anchor' ></a><form method='post' enctype='multipart/form-data' target='gform_ajax_frame_2' id='gform_2'  action='/blog/2017/05/23/councilors-suggest-bell-forcing-lundy-office/#gf_2'>
                        <div class='gform_heading'>
                            <h3 class='gform_title'>Subscribe to Weld Direct</h3>
                            <span class='gform_description'>Get the best of Weld and exclusive deals direct to your inbox.</span>
                        </div>
                        <div class='gform_body'><ul id='gform_fields_2' class='gform_fields top_label form_sublabel_below description_below'><li id='field_2_1' class='gfield field_sublabel_below field_description_below gfield_visibility_visible' ><label class='gfield_label' for='input_2_1' ></label><div class='ginput_container ginput_container_text'><input name='input_1' id='input_2_1' type='text' value='email@example.com' class='large'  tabindex='1'    aria-invalid="false" /></div></li>
                            </ul></div>
        <div class='gform_footer top_label'> <input type='submit' id='gform_submit_button_2' class='gform_button button' value='Sign Me Up' tabindex='2' onclick='if(window["gf_submitting_2"]){return false;}  window["gf_submitting_2"]=true;  ' onkeypress='if( event.keyCode == 13 ){ if(window["gf_submitting_2"]){return false;} window["gf_submitting_2"]=true;  jQuery("#gform_2").trigger("submit",[true]); }' /> <input type='hidden' name='gform_ajax' value='form_id=2&amp;title=1&amp;description=1&amp;tabindex=1' />
            <input type='hidden' class='gform_hidden' name='is_submit_2' value='1' />
            <input type='hidden' class='gform_hidden' name='gform_submit' value='2' />
            
            <input type='hidden' class='gform_hidden' name='gform_unique_id' value='' />
            <input type='hidden' class='gform_hidden' name='state_2' value='WyJbXSIsImJjZTI2ZmM3ZjE4MDY5ZjZhOWRjM2UyY2IyMGY1NGFiIl0=' />
            <input type='hidden' class='gform_hidden' name='gform_target_page_number_2' id='gform_target_page_number_2' value='0' />
            <input type='hidden' class='gform_hidden' name='gform_source_page_number_2' id='gform_source_page_number_2' value='1' />
            <input type='hidden' name='gform_field_values' value='' />
            
        </div>
                        </form>
                        </div>
                <iframe style='display:none;width:0px;height:0px;' src='about:blank' name='gform_ajax_frame_2' id='gform_ajax_frame_2'>This iframe contains the logic required to handle AJAX powered Gravity Forms.</iframe>
                <script type='text/javascript'>jQuery(document).ready(function($){gformInitSpinner( 2, 'http://weldbham.com/wp-content/plugins/gravityforms/images/spinner.gif' );jQuery('#gform_ajax_frame_2').load( function(){var contents = jQuery(this).contents().find('*').html();var is_postback = contents.indexOf('GF_AJAX_POSTBACK') >= 0;if(!is_postback){return;}var form_content = jQuery(this).contents().find('#gform_wrapper_2');var is_confirmation = jQuery(this).contents().find('#gform_confirmation_wrapper_2').length > 0;var is_redirect = contents.indexOf('gformRedirect(){') >= 0;var is_form = form_content.length > 0 && ! is_redirect && ! is_confirmation;if(is_form){jQuery('#gform_wrapper_2').html(form_content.html());if(form_content.hasClass('gform_validation_error')){jQuery('#gform_wrapper_2').addClass('gform_validation_error');} else {jQuery('#gform_wrapper_2').removeClass('gform_validation_error');}setTimeout( function() { /* delay the scroll by 50 milliseconds to fix a bug in chrome */ jQuery(document).scrollTop(jQuery('#gform_wrapper_2').offset().top); }, 50 );if(window['gformInitDatepicker']) {gformInitDatepicker();}if(window['gformInitPriceFields']) {gformInitPriceFields();}var current_page = jQuery('#gform_source_page_number_2').val();gformInitSpinner( 2, 'http://weldbham.com/wp-content/plugins/gravityforms/images/spinner.gif' );jQuery(document).trigger('gform_page_loaded', [2, current_page]);window['gf_submitting_2'] = false;}else if(!is_redirect){var confirmation_content = jQuery(this).contents().find('#gforms_confirmation_message_2').html();if(!confirmation_content){confirmation_content = contents;}setTimeout(function(){jQuery('#gform_wrapper_2').replaceWith('<' + 'div id=\'gforms_confirmation_message_2\' class=\'gform_confirmation_message_2 gforms_confirmation_message\'' + '>' + confirmation_content + '<' + '/div' + '>');jQuery(document).scrollTop(jQuery('#gforms_confirmation_message_2').offset().top);jQuery(document).trigger('gform_confirmation_loaded', [2]);window['gf_submitting_2'] = false;}, 50);}else{jQuery('#gform_2').append(contents);if(window['gformRedirect']) {gformRedirect();}}jQuery(document).trigger('gform_post_render', [2, current_page]);} );} );</script><script type='text/javascript'> if(typeof gf_global == 'undefined') var gf_global = {"gf_currency_config":{"name":"U.S. Dollar","symbol_left":"$","symbol_right":"","symbol_padding":"","thousand_separator":",","decimal_separator":".","decimals":2},"base_url":"http:\/\/weldbham.com\/wp-content\/plugins\/gravityforms","number_formats":[],"spinnerUrl":"http:\/\/weldbham.com\/wp-content\/plugins\/gravityforms\/images\/spinner.gif"};jQuery(document).bind('gform_post_render', function(event, formId, currentPage){if(formId == 2) {} } );jQuery(document).bind('gform_post_conditional_logic', function(event, formId, fields, isInit){} );</script><script type='text/javascript'> jQuery(document).ready(function(){jQuery(document).trigger('gform_post_render', [2, 1]) } ); </script>
					</div>
				</div>
			</div>
</div>
		</aside><aside id="text-15" class="widget widget_text widget-widget_text">			<div class="textwidget"><div class="twitter-follow">
<h3><span class="smaller">Follow Us</span>&nbsp;@WeldBham</h3>
<a href="https://twitter.com/weldbham" class="twitter-follow-button" data-show-count="true">Follow @weldbham</a>
</div></div>
		</aside><aside id="text-17" class="widget widget_text widget-widget_text">			<div class="textwidget"><div id="adWrapper">
<div id="floatingAd" class="sidebar-ad">
<!-- Weld-Index-Floating -->
<script type='text/javascript'>
		if ( window.innerWidth >= 728 && window.innerWidth < 950 ) {
			GA_googleFillSlot("Weld-Index-Floating_Mobile");
		} else {
			GA_googleFillSlot("Weld-Index-Floating");
		}
</script>
</div>
</div></div>
		</aside>
		
	</div><!-- #sidebar-primary .aside -->

				
				<div class="clearfix"></div>
			</div><!-- .wrap -->

						
		</div><!-- #main -->

		
	</div><!-- #container -->
	<div class="clearfix"></div>
	
			
	<footer id="footer" role="contentinfo">

		
		<div class="wrap">

			<p class="copyright">Copyright &#169; 2017 <a class="site-link" href="http://weldbham.com" title="Weld: Birmingham&#039;s Newspaper" rel="home"><span>Weld: Birmingham&#039;s Newspaper</span></a> <br />
			Web Development by <a href="http://infomedia.com">Infomedia</a></p>

			<div class="credit"><div class="menu"><ul id="menu-primary-items" class="nav-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-11174"><a href="http://weldbham.com/">Home</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12085"><a href="http://weldbham.com/login/">Login</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-11136"><a href="http://weldbham.com/about/">About Us</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-post menu-item-26275"><a href="http://weldbham.com/blog/2017/05/01/documenting-hate-weld-new-american-media/">&#8220;Documenting Hate&#8221;</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-11135"><a href="http://weldbham.com/advertise/">Advertise</a></li>
</ul></div></div>

			
		</div><!-- .wrap -->

		
	</footer><!-- #footer -->

	
	<script type="text/javascript">/* <![CDATA[ */ jQuery(document).ready( function() { jQuery.post( "http://weldbham.com/wp-admin/admin-ajax.php", { action : "entry_views", _ajax_nonce : "e6ac441800", post_id : 26397 } ); } ); /* ]]> */</script>
<link rel='stylesheet' id='gforms_reset_css-css'  href='http://weldbham.com/wp-content/plugins/gravityforms/css/formreset.min.css?ver=2.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='gforms_formsmain_css-css'  href='http://weldbham.com/wp-content/plugins/gravityforms/css/formsmain.min.css?ver=2.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='gforms_ready_class_css-css'  href='http://weldbham.com/wp-content/plugins/gravityforms/css/readyclass.min.css?ver=2.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='gforms_browsers_css-css'  href='http://weldbham.com/wp-content/plugins/gravityforms/css/browsers.min.css?ver=2.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='gravityformsmailchimp_form_settings-css'  href='http://weldbham.com/wp-content/plugins/gravityformsmailchimp/css/form_settings.css?ver=4.1' type='text/css' media='all' />
<link rel='stylesheet' id='yarppRelatedCss-css'  href='http://weldbham.com/wp-content/plugins/yet-another-related-posts-plugin/style/related.css?ver=4.7.3' type='text/css' media='all' />
<script type='text/javascript' src='http://weldbham.com/wp-content/themes/weldbham/js/fitvids.js?ver=20120206'></script>
<script type='text/javascript' src='http://weldbham.com/wp-content/themes/weldbham/js/weldbham-custom.js?ver=20120206'></script>
<script type='text/javascript' src='http://weldbham.com/wp-content/themes/weldbham/fundraiser/js/cookie.js?ver=1479251953'></script>
<script type='text/javascript' src='http://weldbham.com/wp-content/themes/weldbham/fundraiser/js/fundraiser.js?ver=1493662301'></script>
<script type='text/javascript' src='http://weldbham.com/wp-content/themes/weldbham/js/small-menu-secondary.js?ver=20120206'></script>
<script type='text/javascript' src='http://weldbham.com/wp-includes/js/comment-reply.min.js?ver=4.7.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var FB_WP=FB_WP||{};FB_WP.queue={_methods:[],flushed:false,add:function(fn){FB_WP.queue.flushed?fn():FB_WP.queue._methods.push(fn)},flush:function(){for(var fn;fn=FB_WP.queue._methods.shift();){fn()}FB_WP.queue.flushed=true}};window.fbAsyncInit=function(){FB.init({"xfbml":true,"appId":"199569796846147"});if(FB_WP && FB_WP.queue && FB_WP.queue.flush){FB_WP.queue.flush()}}
/* ]]> */
</script>
<script type="text/javascript">(function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(d.getElementById(id)){return}js=d.createElement(s);js.id=id;js.src="http:\/\/connect.facebook.net\/en_US\/all.js";fjs.parentNode.insertBefore(js,fjs)}(document,"script","facebook-jssdk"));</script>
<script type='text/javascript' src='http://weldbham.com/wp-includes/js/wp-embed.min.js?ver=4.7.3'></script>
<script type='text/javascript' src='http://weldbham.com/wp-content/plugins/gravityforms/js/jquery.json.min.js?ver=2.2.1'></script>
<script type='text/javascript' src='http://weldbham.com/wp-content/plugins/gravityforms/js/gravityforms.min.js?ver=2.2.1'></script>
<script type='text/javascript' src='http://weldbham.com/wp-content/plugins/gravityforms/js/conditional_logic.min.js?ver=2.2.1'></script>
<script type='text/javascript' src='http://weldbham.com/wp-content/plugins/gravityforms/js/placeholders.jquery.min.js?ver=2.2.1'></script>
<div id="fb-root"></div>
</body>
</html>